aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoakim Karlsson <oakimk@gmail.com>2018-12-17 23:52:07 +0100
committerGerald Combs <gerald@wireshark.org>2018-12-19 18:31:19 +0000
commitf01a9d9fe85b6dd8720bd5f8cf420c5f74e254f1 (patch)
tree34ce9baa9047700212fa7984ff9554380e9c39fa /CMakeLists.txt
parent75be0027d0a0c2e385ef318d677becb9a850c104 (diff)
CMake: make use of sdjournal build flag
With this change CMake will not build sdjournal when feature turned off Change-Id: I896c8286b95abdf7ec668c4ab6c8dfacc930be03 Reviewed-on: https://code.wireshark.org/review/31086 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77b0874765..b9b3bee888 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -943,7 +943,7 @@ if(ENABLE_AIRPCAP)
set(PACKAGELIST ${PACKAGELIST} AIRPCAP)
endif()
-if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+if(BUILD_sdjournal)
set(PACKAGELIST ${PACKAGELIST} Systemd)
endif()