aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2015-11-05 18:31:11 +0100
committerMichael Mann <mmann78@netscape.net>2015-12-22 12:24:16 +0000
commitac0eb6043be787428a194c163b55c852c8cb5be2 (patch)
tree74a195f4a020453d811127323e95da2ef80627d6 /CMakeLists.txt
parent0e4a7429db488b25941be4aa66405f9c2f4915e5 (diff)
extcap: add randpktdump, a random packet generator.
This new extcap is for testing and educational purpose. It relies on rankpkt-core functions to generate random packets. Change-Id: If6890f0673545682995a2079458108edc0913b30 Reviewed-on: https://code.wireshark.org/review/11764 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 42216774db..4316646eb6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1306,6 +1306,7 @@ set(INSTALL_FILES
${CMAKE_BINARY_DIR}/mergecap.html
pdml2html.xsl
${CMAKE_BINARY_DIR}/randpkt.html
+ ${CMAKE_BINARY_DIR}/randpktdump.html
${CMAKE_BINARY_DIR}/rawshark.html
${CMAKE_BINARY_DIR}/reordercap.html
services
@@ -1337,6 +1338,7 @@ set(MAN1_FILES
${CMAKE_BINARY_DIR}/idl2wrs.1
${CMAKE_BINARY_DIR}/mergecap.1
${CMAKE_BINARY_DIR}/randpkt.1
+ ${CMAKE_BINARY_DIR}/androiddump.1
${CMAKE_BINARY_DIR}/rawshark.1
${CMAKE_BINARY_DIR}/reordercap.1
${CMAKE_BINARY_DIR}/sshdump.1
@@ -2368,6 +2370,24 @@ elseif (BUILD_sshdump)
#message( WARNING "Cannot find libssh, cannot build sshdump" )
endif()
+if(BUILD_randpktdump)
+ set(randpktdump_LIBS
+ wiretap
+ ${GLIB2_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+ )
+ set(randpktdump_FILES
+ extcap/randpktdump.c
+ randpkt-core.c
+ )
+
+ add_executable(randpktdump WIN32 ${randpktdump_FILES})
+ # XXX Shouldn't we add wsutil to randpktdump_LIBS instead?
+ set_extcap_executable_properties(randpktdump)
+ target_link_libraries(randpktdump ${randpktdump_LIBS})
+ install(TARGETS randpktdump RUNTIME DESTINATION ${EXTCAP_DIR})
+endif()
+
ADD_CUSTOM_COMMAND(
OUTPUT ${CMAKE_BINARY_DIR}/AUTHORS-SHORT
COMMAND ${PERL_EXECUTABLE}
@@ -2487,6 +2507,7 @@ pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/idl2deb 1 )
pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/idl2wrs 1 )
pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/mergecap 1 )
pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/randpkt 1 )
+pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/randpktdump 1 )
pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/rawshark 1 )
pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/reordercap 1 )
pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/sshdump 1 )
@@ -2510,6 +2531,7 @@ add_custom_target(
idl2wrs.html
mergecap.html
randpkt.html
+ randpktdump.html
rawshark.html
reordercap.html
sshdump.html
@@ -2526,6 +2548,7 @@ set(CLEAN_FILES
${rawshark_FILES}
${dftest_FILES}
${randpkt_FILES}
+ ${randpktdump_FILES}
${text2pcap_CLEAN_FILES}
${mergecap_FILES}
${capinfos_FILES}