aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2015-06-12 10:58:37 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2015-06-12 20:36:37 +0000
commita57398dacb44b537d2fba0c0ce0c64a2d61a65ed (patch)
tree04b88863265707d38cb957b27794d3cc7fe03ba8 /CMakeLists.txt
parent905506fd9828a72607b7fd2011f2c23486b615d9 (diff)
Fix some CMake compiler tests for Win64
Change-Id: I03244b48e6593d1fe5f4d139fa5d171debeb9fd7 Reviewed-on: https://code.wireshark.org/review/8909 Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ed03149bc..d8b2384bad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -269,7 +269,7 @@ if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
set(LOCAL_CFLAGS ${LOCAL_CFLAGS} "/Zo")
endif()
- if(NOT WIN64)
+ if(NOT "${WIRESHARK_TARGET_PLATFORM}" STREQUAL "win64")
set(LOCAL_CFLAGS ${LOCAL_CFLAGS} "/D_BIND_TO_CURRENT_CRT_VERSION=1")
endif()