aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2019-01-20 22:10:46 +0000
committerPeter Wu <peter@lekensteyn.nl>2019-01-21 12:01:56 +0000
commita37388fbb6bd45f1376e865c02410abf59e6bc2a (patch)
treebec516854f635d9ed5f814af3887e50fa1e5ba9e /CMakeLists.txt
parent965248dcfbf53c792ec797fc0c10ffbdd902abc9 (diff)
CMake: Remove unnecessary check for CMAKE_INSTALL_RPATH
CMAKE_INSTALL_RPATH is set inside the if() block and not before. Change-Id: Id8a863ca9bf5fed367de3fa7681a9a269d3f4f07 Reviewed-on: https://code.wireshark.org/review/31646 Reviewed-by: João Valverde <j@v6e.pt> Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a5c9e2f5a3..99fb4f3e5b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -181,7 +181,7 @@ include(GNUInstallDirs)
# Make sure our executables can can load our libraries if we install into
# a non-default directory on Unix-like systems other than macOS.
# https://gitlab.kitware.com/cmake/community/wikis/doc/cmake/RPATH-handling
-if(NOT CMAKE_INSTALL_RPATH AND NOT (WIN32 OR APPLE))
+if(NOT (WIN32 OR APPLE))
# Try to set a RPATH for installed binaries if the library directory is
# not already included in the default search list.
list(FIND CMAKE_C_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_FULL_LIBDIR}" IS_SYSTEM_DIR)