aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAtli Guðmundsson <atli@tern.is>2018-12-25 14:13:40 +0000
committerPeter Wu <peter@lekensteyn.nl>2018-12-26 16:52:40 +0000
commita051c12f2caa82e51e29225d26ba85e34689a1a1 (patch)
treea97e93f02c10601f740736e41bdc02b227b4ddcf /CMakeLists.txt
parent796dca3c2a5259af62d89519193308d71774c2a9 (diff)
Added a generic dissector validator and some ASTERIX unit tests that use it.
This patch extends the test suite with: * a way for tests to check if a given byte sequence dissects into an expected dissection result. Unit tests included: * ASTERIX I019 * ASTERIX I063 * ASTERIX I065 Change-Id: Ib168382ec15b0b610ff5913806120ba1bf1d1503 Reviewed-on: https://code.wireshark.org/review/31083 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5975b78d68..9e4610e9c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3122,6 +3122,7 @@ set(_test_group_list
suite_dfilter.group_tvb
suite_dfilter.group_uint64
suite_dissection
+ suite_dissectors.group_asterix
suite_fileformats
suite_follow
suite_io