aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-10-09 13:40:12 -0700
committerGerald Combs <gerald@wireshark.org>2019-10-10 16:06:33 +0000
commit926d5504f775b75168d1e49a154b8daea12fdc1d (patch)
tree014c111cff533e54cfe8cf2224a3cebdc5557bf8 /CMakeLists.txt
parent97cb389a3531269b3c86555156a2bba62ccfd8a5 (diff)
CMake: Remove some header defines.
It looks like HAVE_SYS_TYPES_H, HAVE_STDINT_H, and HAVE_STDDEF_H were required for check_type_size via test_big_endian, but we don't use that any more. HAVE_LRINT was used by the GTK+ UI. Change-Id: I6474c118bac4413791b3613d34d263e38107600a Reviewed-on: https://code.wireshark.org/review/34754 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f9ae5d57ca..88a9884af3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -128,13 +128,6 @@ if(WIN32)
# on Windows can be slow.
set(HAVE_FCNTL_H TRUE)
set(HAVE_FLOORL TRUE)
- set(HAVE_LRINT TRUE)
-
- # It looks like we call check_type_size somewhere, which checks
- # for these.
- set(HAVE_SYS_TYPES_H TRUE)
- set(HAVE_STDINT_H TRUE)
- set(HAVE_STDDEF_H TRUE)
endif(WIN32)
include(UseCustomIncludes)