aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2012-11-01 23:09:02 +0000
committerJörg Mayer <jmayer@loplof.de>2012-11-01 23:09:02 +0000
commit854ae179efe6c64639f6ba2aba25b58b4f572444 (patch)
tree563e1d499589863d2e7bb6451b44e4558cfeb776 /CMakeLists.txt
parent66b13e296130a477742c26e4f4b0f4fe4ad9df39 (diff)
Fix ui/qt/print_dialog.cpp:228:23: error: variable ‘status’ set but not used [-Werror=unused-but-set-variable]
svn path=/trunk/; revision=45864
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e493ded9ce..cd4cd021c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -126,6 +126,7 @@ set(WIRESHARK_C_FLAGS
-Wcast-align
-Wformat-security
-fexcess-precision=fast
+ # -fvisibility=hidden
)
set(WIRESHARK_C_ONLY_FLAGS
@@ -508,7 +509,12 @@ endif()
#Platform specific
if(UNIX)
- set(WS_VAR_IMPORT "extern")
+ if(CMAKE_COMPILER_IS_GNUCC)
+ # set(WS_VAR_IMPORT "__attribute__((visibility(\"default\")))" )
+ set(WS_VAR_IMPORT "extern")
+ else()
+ set(WS_VAR_IMPORT "extern")
+ endif()
endif()
if(APPLE)