aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2012-09-14 20:23:18 +0000
committerGerald Combs <gerald@wireshark.org>2012-09-14 20:23:18 +0000
commit762e5ac93f08912c6daae6e83033b01332e914ab (patch)
treeb7782b13f2ffe300f89dd3144a341b33afd4c363 /CMakeLists.txt
parent670dff46e451ca0e701bdafb5c13d75c42b261f6 (diff)
Create a common libui using CMake similar to what we do with Autotools.
Move the GTK+ text import code to the common UI directory. Create wtap_encap_requires_phdr() from code in file_import_dlg.c. svn path=/trunk/; revision=44904
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3420bf185b..4021df64f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -471,6 +471,10 @@ add_subdirectory( tools/lemon )
add_subdirectory( wiretap )
add_subdirectory( wsutil )
+if((BUILD_wireshark AND GTK_FOUND) OR (BUILD_qtshark AND QT_FOUND))
+ add_subdirectory( ui )
+endif()
+
if(BUILD_wireshark AND GTK_FOUND)
add_subdirectory( ui/gtk )
endif()
@@ -526,6 +530,7 @@ PRINT_ENABLED_FEATURES()
PRINT_DISABLED_FEATURES()
link_directories(
+ ${CMAKE_BINARY_DIR}/ui
${CMAKE_BINARY_DIR}/ui/gtk
${CMAKE_BINARY_DIR}/ui/qt
${CMAKE_BINARY_DIR}/codecs
@@ -720,9 +725,6 @@ if( (BUILD_wireshark AND GTK_FOUND) OR (BUILD_qtshark AND QT_FOUND) )
summary.c
tempfile.c
u3.c
- ui/alert_box.c
- ui/iface_lists.c
- ui/util.c
ws80211_utils.c
${SHARK_COMMON_CAPTURE_SRC}
${WIRESHARK_COMMON_SRC}
@@ -731,6 +733,7 @@ endif()
if(BUILD_wireshark AND GTK_FOUND)
set(wireshark_LIBS
+ ui
gtkui
${GTK2_LIBRARIES}
${GTK3_LIBRARIES}
@@ -1115,4 +1118,3 @@ if(DOC_DIR)
PATTERN "*.pdf"
)
endif()
-