aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2009-11-08 16:59:15 +0000
committerStig Bjørlykke <stig@bjorlykke.org>2009-11-08 16:59:15 +0000
commit7236f6ed77a37d8485f9b5cd15d8fe74178604a2 (patch)
treed25c0236c7d8257b5e2ac97e48e12954f7480fb5 /CMakeLists.txt
parent1087c4c5008fd4b0e7a481337ed807fd489d5126 (diff)
Make it possible to disable WERROR.
svn path=/trunk/; revision=30864
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9dcd81dc4c..77712d2883 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -164,6 +164,8 @@ endforeach()
if(NOT DISABLE_WERROR AND NOT ENABLE_EXTRA_GCC_CHECKS)
check_c_compiler_flag(-Werror WERROR)
+else()
+ set(WERROR 0)
endif()
if(CMAKE_COMPILER_IS_GNUCC)