aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2018-06-08 18:09:11 +0100
committerPeter Wu <peter@lekensteyn.nl>2018-06-11 17:01:05 +0000
commit722d6b06f606bc045ecef6fe5c8f2c700a3dad65 (patch)
tree4af9a6ad87cd46ff92e7be1b4fb956900bacd30e /CMakeLists.txt
parentbfb7028ba971deb2d3edf7f573b3183ef67ce5c2 (diff)
Rewrite make-{dissectors,taps} in Python
Having these build tools in machine code poses problems when cross-compiling. The most significant being that we need to find the host and build GLiB dependencies at compile-time. There is no noticeable speed difference between the Python and C implementation. Ping-Bug: 14622 Change-Id: Id13f823c7f4abf51edfa291e703028873748989f Reviewed-on: https://code.wireshark.org/review/28130 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 994a748fd3..2e4791ba20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1267,7 +1267,7 @@ add_subdirectory( docbook EXCLUDE_FROM_ALL )
add_subdirectory( epan )
add_subdirectory( extcap )
add_subdirectory( randpkt_core )
-add_subdirectory( tools )
+add_subdirectory( tools/lemon )
add_subdirectory( ui )
add_subdirectory( wiretap )
add_subdirectory( writecap )