aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2012-03-15 21:27:04 +0000
committerJörg Mayer <jmayer@loplof.de>2012-03-15 21:27:04 +0000
commit6b8234e0011a14c92b41662aee72c3a85d684be2 (patch)
tree49d4b3d3dd29cc7fa052b5b4c5791b5079311706 /CMakeLists.txt
parent4d25efa4ad0d865aca80e60fa75f85cd8c910e00 (diff)
Document which warnings are c++ only.
svn path=/trunk/; revision=41574
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 14 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 840925a7c0..b90ca1c8aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -108,15 +108,17 @@ set(WIRESHARK_C_FLAGS
-Wall
-W
-Wextra
- -Wdeclaration-after-statement
-Wendif-labels
-Wpointer-arith
- -Wno-pointer-sign
-Warray-bounds
-Wcast-align
-Wformat-security
- -Wold-style-definition
-fexcess-precision=fast
+
+ # The following are C only, not C++
+ -Wdeclaration-after-statement
+ -Wno-pointer-sign
+ -Wold-style-definition
)
set(WIRESHARK_EXTRA_C_FLAGS
@@ -128,7 +130,6 @@ set(WIRESHARK_EXTRA_C_FLAGS
-Wunreachable-code
-Wunsafe-loop-optimizations
-Wno-long-long
- -Wbad-function-cast
-Wcast-qual
-Waddress
-Warray-bounds
@@ -139,19 +140,23 @@ set(WIRESHARK_EXTRA_C_FLAGS
-Wpragmas
-Wredundant-decls
-Wvla
- -Wc++-compat
- -Wjump-misses-init
# packet-ncp2222.inc prevents this from going into all warnings
-Wwrite-strings
- # GLib blocks this for now.
- -Wstrict-prototypes
# All the registration functions block these for now.
- -Wmissing-prototypes
-Wmissing-declarations
# Problem with packet-afs.c
-Wshadow
# More cleanup needed for this on LP64
-Wshorten-64-to-32
+
+ # The following are C only, not C++
+ -Wbad-function-cast
+ -Wc++-compat
+ -Wjump-misses-init
+ # GLib blocks this for now.
+ -Wstrict-prototypes
+ # All the registration functions block these for now.
+ -Wmissing-prototypes
)
if(ENABLE_EXTRA_GCC_CHECKS) # This overrides -Werror