aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-10-28 16:52:41 -0700
committerGerald Combs <gerald@wireshark.org>2015-10-29 00:52:07 +0000
commit670475413ae7f80a9aea06766c95e05774ba1496 (patch)
tree77acaeecc2674207ebe02879c40fc8e3b8318d41 /CMakeLists.txt
parent6ada7d53899d49f0c173ad241f8e6f5dfee590d9 (diff)
CMake: Use CMAKE_CL_64.
CMake sets CMAKE_CL_64 if we're using a 64-bit version of Visual Studio. Use it. Change-Id: I04595a0e703e39e428d853a506472f3881672a35 Reviewed-on: https://code.wireshark.org/review/11376 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb149ca0ec..f0d0cd2fd1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,7 @@ endif()
if(WIN32)
find_package(PowerShell REQUIRED)
- if("${CMAKE_GENERATOR}" MATCHES "Win64")
+ if(${CMAKE_CL_64} OR "${CMAKE_GENERATOR}" MATCHES "Win64")
set(WIRESHARK_TARGET_PLATFORM win64)
elseif("${CMAKE_GENERATOR}" MATCHES "Visual Studio")
set(WIRESHARK_TARGET_PLATFORM win32)