aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2016-03-04 15:22:59 +0100
committerDario Lombardo <lomato@gmail.com>2016-03-04 15:30:24 +0000
commit637aefd2b3730ef8eba360040c848205e5c3e7f3 (patch)
treea848ec797360587eea4d3937cddfb7737e182492 /CMakeLists.txt
parentb4f3255450c5e7d13ff5ac2c3dfe1fe678151b8b (diff)
cmake: fix gen-authors target.
Also add AUTHORS.git to .gitignore. Change-Id: I63365816fc32b33d064ebbcae0ddb607c2b37f38 Reviewed-on: https://code.wireshark.org/review/14339 Petri-Dish: Dario Lombardo <lomato@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net> Reviewed-by: Dario Lombardo <lomato@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d0052d0162..e6ad9873d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2700,7 +2700,7 @@ add_custom_target(test-sh
)
ADD_CUSTOM_TARGET(
- gen-authors ALL
+ gen-authors
COMMAND git shortlog -sne | cut -c8- > ${CMAKE_SOURCE_DIR}/AUTHORS.git
COMMAND ${PERL_EXECUTABLE} ${CMAKE_SOURCE_DIR}/tools/generate_authors.pl ${CMAKE_SOURCE_DIR}/AUTHORS.src ${CMAKE_SOURCE_DIR}/AUTHORS.git > ${CMAKE_SOURCE_DIR}/AUTHORS