aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-18 17:31:09 +0000
committerJoão Valverde <j@v6e.pt>2016-03-21 17:10:21 +0000
commit52dd4fb6330a10ed37b8e221c502b5a98de4f581 (patch)
tree9d3ea5b26003115f61ac5af0d9dd7997cbe7cfb2 /CMakeLists.txt
parent69d348c12a2d86e5fa75189cd2dd5f4f3784dcfc (diff)
Fix building without extcap enabled
Using cmake -DENABLE_EXTCAP=no or ./configure --without-extcap. Some documentation fixes too. Change-Id: Iebf9c843d67e10a32de1a62904de8f88b872ec99 Reviewed-on: https://code.wireshark.org/review/14522 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4230191aaf..f609b8e045 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2328,7 +2328,7 @@ if (WIN32)
endif()
endif()
-if(BUILD_androiddump)
+if(ENABLE_EXTCAP AND BUILD_androiddump)
if(EXTCAP_ANDROIDDUMP_LIBPCAP)
if(HAVE_LIBPCAP)
set(androiddump_LIBS
@@ -2357,7 +2357,7 @@ if(BUILD_androiddump)
install(TARGETS androiddump RUNTIME DESTINATION ${EXTCAP_DIR})
endif()
-if(BUILD_sshdump AND LIBSSH_FOUND)
+if(ENABLE_EXTCAP AND BUILD_sshdump AND LIBSSH_FOUND)
set(sshdump_LIBS
wsutil
${GLIB2_LIBRARIES}
@@ -2382,7 +2382,7 @@ elseif (BUILD_sshdump)
#message( WARNING "Cannot find libssh, cannot build sshdump" )
endif()
-if(BUILD_randpktdump)
+if(ENABLE_EXTCAP AND BUILD_randpktdump)
set(randpktdump_LIBS
randpkt_core
wiretap