aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2019-01-12 16:33:39 +0100
committerPeter Wu <peter@lekensteyn.nl>2019-01-12 18:20:52 +0000
commit4de0ea38cdb46f925fe7b0d8a7a4096442b501f9 (patch)
tree3f415d760e1b8ecfbfc087615a2edf17b8038d43 /CMakeLists.txt
parent5cc461490d817be898629562b947099a9996f198 (diff)
CMake: change static qtui library into an object library
Save 800ms and avoids a synchronization point (improves build parallelism) by directly adding object files to the wireshark binary. Change-Id: I7d1484c65a26f3f6874474b61d38ba474aba8347 Reviewed-on: https://code.wireshark.org/review/31512 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 912a47562d..95dac86105 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2134,6 +2134,7 @@ if(BUILD_wireshark AND QT_FOUND)
)
set(wireshark_FILES
$<TARGET_OBJECTS:capture_opts>
+ $<TARGET_OBJECTS:qtui>
$<TARGET_OBJECTS:shark_common>
$<TARGET_OBJECTS:version_info>
${WIRESHARK_SRC}
@@ -2215,7 +2216,6 @@ endif()
if(BUILD_wireshark AND QT_FOUND)
set(wireshark_LIBS
- qtui
ui
capchild
caputils
@@ -2232,6 +2232,7 @@ if(BUILD_wireshark AND QT_FOUND)
${NL_LIBRARIES}
${WIN_VERSION_LIBRARY}
${WINSPARKLE_LIBRARIES}
+ $<$<BOOL:${WIN32}>:UxTheme.lib>
)
add_executable(wireshark WIN32 MACOSX_BUNDLE ${wireshark_FILES} ${EXTRA_BUNDLE_FILES})