aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2019-05-01 16:13:28 +0100
committerJoão Valverde <j@v6e.pt>2019-05-03 21:56:45 +0000
commit4c5d2f5ccf822c07746853b065322c34dc322e8a (patch)
tree36cbd1b226a137eb38cf1e900b86e547235abd7e /CMakeLists.txt
parente5b4e673f0534fd26919cb7d3644b958d3020bea (diff)
CMake: Add libpcap imported library target
Change-Id: I5326b87784817fb353329e2d686fe0515c32f6cb Reviewed-on: https://code.wireshark.org/review/33038 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e44f96849..4a51b61d1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2433,7 +2433,6 @@ if(BUILD_randpkt)
wiretap
wsutil
${M_LIBRARIES}
- ${PCAP_LIBRARIES}
${CARES_LIBRARIES}
${ZLIB_LIBRARIES}
)
@@ -2580,7 +2579,7 @@ if(BUILD_dumpcap AND PCAP_FOUND)
wsutil
caputils
ui
- ${PCAP_LIBRARIES}
+ $<$<BOOL:${PCAP_FOUND}>:pcap::pcap>
${CAP_LIBRARIES}
${GLIB2_LIBRARIES}
${GTHREAD2_LIBRARIES}