aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2015-06-02 22:11:56 +0100
committerAnders Broman <a.broman58@gmail.com>2015-06-03 08:00:10 +0000
commit2adeb9969f2ccec30a3746286a4dd152aa657706 (patch)
tree38183739853a0343d552040fb02251ba845464e6 /CMakeLists.txt
parentec3f923e3e693a3ca469bb7073a8c9ce2c33cb7d (diff)
Fix OSX CMake warnings
Set the CMake policy for CMP0042 to old Change-Id: I2b71e1d8d9b9b90ede11df1a7874a2360c3032c5 Reviewed-on: https://code.wireshark.org/review/8740 Reviewed-by: Graham Bloice <graham.bloice@trihedral.com> Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a1d963ac92..3ed03149bc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,11 @@ if (POLICY CMP0054)
cmake_policy(SET CMP0054 OLD)
endif()
+# Set old behaviour for MACOSX_RPATH
+if (POLICY CMP0042)
+ cmake_policy(SET CMP0042 OLD)
+endif()
+
# If our target platform is enforced by our generator, set
# WIRESHARK_TARGET_PLATFORM accordingly. Otherwise use
# %WIRESHARK_TARGET_PLATFORM%.