aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2019-01-31 11:43:04 +0100
committerPeter Wu <peter@lekensteyn.nl>2019-01-31 13:15:58 +0000
commit298da5213bdaec381f6548b45982505eef0e78ae (patch)
treedae9ec068f42ce09781a956c1f65e265b4daf8d9 /CMakeLists.txt
parent87e5269c69157c071fbe7f62f6b4c0b76cd2c713 (diff)
CMake: describe the purpose of NL
Change-Id: I9bfb2400445399088ff67eab39178e38daf85499 Reviewed-on: https://code.wireshark.org/review/31835 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7b222c8817..cf5990e23d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1478,6 +1478,11 @@ set_package_properties(Systemd PROPERTIES
DESCRIPTION "System and Service Manager (libraries)"
PURPOSE "Support for systemd journal extcap interface (sdjournal)"
)
+set_package_properties(NL PROPERTIES
+ URL "https://www.infradead.org/~tgr/libnl/"
+ DESCRIPTION "Libraries for using the Netlink protocol on Linux"
+ PURPOSE "Support for managing wireless 802.11 interfaces"
+)
string(TOUPPER "${CMAKE_BUILD_TYPE}" _build_type)
message(STATUS "C-Flags: ${CMAKE_C_FLAGS} ${CMAKE_C_FLAGS_${_build_type}}")