aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Labedzki <michal.labedzki@tieto.com>2015-04-16 08:04:58 +0200
committerMichal Labedzki <michal.labedzki@tieto.com>2015-04-17 16:03:48 +0000
commit1948d026f6e89e3346ce1b0a45a6a2bf24e577d9 (patch)
treeea6c05eb698f724f7b79129d18708e8ffe7e0495 /CMakeLists.txt
parentbd586170634d6363a164ace9254c85c64f86a0f6 (diff)
androiddump: Fix build on onther than Win platforms
androiddump should be put in extcat directory. Change-Id: I360eef2d5a68178c73181949b0fe3346585f5190 Reviewed-on: https://code.wireshark.org/review/8083 Petri-Dish: Michal Labedzki <michal.labedzki@tieto.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michal Labedzki <michal.labedzki@tieto.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 844d4afe36..c8576b0c69 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1789,7 +1789,10 @@ macro(set_extcap_executable_properties _executable)
RUNTIME_OUTPUT_DIRECTORY_RELWITHDEBINFO ${CMAKE_BINARY_DIR}/run/RelWithDebInfo/extcap
)
else()
- set_target_properties(${_executable} PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
+ set_target_properties(${_executable} PROPERTIES
+ LINK_FLAGS "${WS_LINK_FLAGS}"
+ RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/run/extcap
+ )
endif()
endmacro()