aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2012-06-07 22:41:42 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2012-06-07 22:41:42 +0200
commit0d70522eda026024d510d53a610029f63f0f865b (patch)
tree51017817acfff166fcac423be80ea4639d6db3e0 /configure.ac
parent1686a0f905eda19a0e92ec9490065621bc36c4df (diff)
automake: define pkg-config variables
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3703c37..c879f4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,10 @@ AC_HEADER_STDC
AC_CHECK_HEADERS(sys/types.h)
AC_CHECK_HEADERS(pthread.h,, [AC_MSG_ERROR([pthread.h required])])
+# pc variables
+AC_SUBST(RTLSDR_PC_LIBS,["$LIBS"])
+AC_SUBST(RTLSDR_PC_CFLAGS,["$CFLAGS"])
+
dnl checks for required libraries
dnl pthreads
AC_CHECK_LIB(pthread, pthread_create, [LIBS="$LIBS -lpthread"])