summaryrefslogtreecommitdiffstats
path: root/src/host/virt_phy/src/Makefile.am
diff options
context:
space:
mode:
authorSebastian Stumpf <sebastian.stumpf87@googlemail.com>2017-03-04 18:17:27 +0100
committerHarald Welte <laforge@gnumonks.org>2017-07-12 23:26:26 +0200
commitc1705d53db746551a12fe85229bda41a4d5b508a (patch)
tree2756d5d80f0cf419c248a333632ceeeddfcabeb8 /src/host/virt_phy/src/Makefile.am
parente7600a0d57c5f1c0add894cdba7904a73775ca1f (diff)
VIRT-PHY: Fixed power management and PCS sync.
PCS flag was ignored in fbsb. Power management returned a perfect link for all possible arfcns causing the mobile trying to sync to all these afterwards. This took too long and PM now only returnes a good link quality for arfcns configured as available. Power management was also extracted to an own file. Change-Id: Ia1b79aa47c9df3b1e316122455ceccb4a66724e0
Diffstat (limited to 'src/host/virt_phy/src/Makefile.am')
-rw-r--r--src/host/virt_phy/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/host/virt_phy/src/Makefile.am b/src/host/virt_phy/src/Makefile.am
index ae14ef6f..d34b8adc 100644
--- a/src/host/virt_phy/src/Makefile.am
+++ b/src/host/virt_phy/src/Makefile.am
@@ -4,7 +4,7 @@ AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_srcdir)/../layer2
CFLAGS = "-g -O0"
sbin_PROGRAMS = virtphy
-virtphy_SOURCES = virtphy.c l1ctl_sock.c gsmtapl1_if.c l1ctl_sap.c virt_prim_fbsb.c virt_prim_rach.c virt_prim_data.c virt_prim_traffic.c virt_l1_sched_simple.c logging.c virt_l1_model.c shared/virtual_um.c shared/osmo_mcast_sock.c
+virtphy_SOURCES = virtphy.c l1ctl_sock.c gsmtapl1_if.c l1ctl_sap.c virt_prim_pm.c virt_prim_fbsb.c virt_prim_rach.c virt_prim_data.c virt_prim_traffic.c virt_l1_sched_simple.c logging.c virt_l1_model.c shared/virtual_um.c shared/osmo_mcast_sock.c
virtphy_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
virtphy_LDFLAGS = -pthread