summaryrefslogtreecommitdiffstats
path: root/src/host/virt_phy/src/Makefile.am
diff options
context:
space:
mode:
authorSebastian Stumpf <sebastian.stumpf87@googlemail.com>2017-02-06 14:14:31 +0100
committerHarald Welte <laforge@gnumonks.org>2017-07-12 23:26:26 +0200
commit2e265c897a7a1d099c08807f0587dfbfc83f260d (patch)
treeee09836ac1fd18fb1c35279195a0fe1f570e6f4b /src/host/virt_phy/src/Makefile.am
parentfa2ce6396fae18ded5bb9620b4ab761ab417c4ba (diff)
VIRT-PHY: Cleanup dirs, makefile, dependencies and formatting code.
Diffstat (limited to 'src/host/virt_phy/src/Makefile.am')
-rw-r--r--src/host/virt_phy/src/Makefile.am14
1 files changed, 2 insertions, 12 deletions
diff --git a/src/host/virt_phy/src/Makefile.am b/src/host/virt_phy/src/Makefile.am
index 2dac297c..85085092 100644
--- a/src/host/virt_phy/src/Makefile.am
+++ b/src/host/virt_phy/src/Makefile.am
@@ -1,18 +1,8 @@
-OSMOCOM_DIR = /home/basti/Osmocom
-OSMO_BB_DIR = $(OSMOCOM_DIR)/osmocom-bb
-OSMO_BTS_DIR = $(OSMOCOM_DIR)/osmo-bts
-OPENBSC_DIR = $(OSMOCOM_DIR)/openbsc
-
AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS)
-AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(OSMO_BB_DIR)/include -I$(OSMO_BTS_DIR)/include -I$(OPENBSC_DIR)/openbsc/include -I$(OSMO_BB_DIR)/src/host/layer23/include
-# TODO: somehow this include path causes errors, thus the needed files are copied into $(top_srcdir)/include. Would be better to include directly from $(OSMO_BB_DIR)/src/target/firmware/include to avoid redundancy.
-# -I$(OSMO_BB_DIR)/src/target/firmware/include
-
-# disable optimization and enable debugging
-CFLAGS = -g -O0
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_srcdir)/../layer23/include
sbin_PROGRAMS = virtphy
-virtphy_SOURCES = virtphy.c l1ctl_sock.c l1ctl_sap.c gsmtapl1_if.c logging.c virt_l1_model.c virtual_um.c osmo_mcast_sock.c
+virtphy_SOURCES = virtphy.c l1ctl_sock.c l1ctl_sap.c gsmtapl1_if.c logging.c virt_l1_model.c shared/virtual_um.c shared/osmo_mcast_sock.c
virtphy_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
# debug output