aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2024-03-18 11:34:57 +0100
committerOliver Smith <osmith@sysmocom.de>2024-03-18 13:44:33 +0100
commitf1ce0e769292f5e71c022a927430dcebe7891d41 (patch)
treebc7ddea5d4f6fd2f1cbf02898db7f84c344ad958 /debian/rules
parent99e0746f371256df78def8299ed13a1ff09b89a1 (diff)
debian/rules: make configure args diff friendly
Have one arg per line, and order it mostly alphabetically while at it (backends are still together, as recommended in review). Change-Id: I354affacb38958efe70baedc6175aeab525190a6
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5795643..e6cac87 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,7 +9,14 @@ override_dh_shlibdeps:
dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
override_dh_auto_configure:
- dh_auto_configure -- --with-uhd --with-usrp1 --with-lms --with-ipc --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
+ dh_auto_configure -- \
+ --enable-manuals \
+ --with-systemdsystemunitdir=/lib/systemd/system \
+ --with-ipc \
+ --with-lms \
+ --with-uhd \
+ --with-usrp1 \
+ $(NULL)
override_dh_strip:
dh_strip --dbg-package=osmo-trx-dbg