aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-05-22 14:10:01 +0200
committerOliver Smith <osmith@sysmocom.de>2019-05-29 12:14:24 +0200
commit76a5013c914a152cd3f7a80488953946ad353441 (patch)
treec197214fcf2cedb5253cdc0621d90b7d22f69990 /debian/rules
parent928177125654c1e596ec3450a68882c031ebb929 (diff)
debian: create -doc subpackage with pdf manuals
I have verified, that the resulting debian packages build in my own OBS namespace (see the -doc packages): https://download.opensuse.org/repositories/home:/osmith42/Debian_9.0/all/ https://build.opensuse.org/project/show/home:osmith42 Depends: Ib7251cca9116151e473798879375cd5eb48ff3ad (osmo-ci) Related: OS#3899 Change-Id: I34858a18a34fc467f274ac164697a242f4cf0df8
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 68de706..627c0c8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,7 +9,11 @@ override_dh_shlibdeps:
dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
override_dh_auto_configure:
- dh_auto_configure -- --with-uhd --with-usrp1 --with-lms --with-systemdsystemunitdir=/lib/systemd/system
+ dh_auto_configure -- --with-uhd --with-usrp1 --with-lms --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
override_dh_strip:
dh_strip --dbg-package=osmo-trx-dbg
+
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+ dh_compress -X.pdf