aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/device/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2019-05-03 21:08:40 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2019-05-06 11:23:18 +0200
commitb5def414b8c485c8fb434a427ed8f4df427ae224 (patch)
tree2239221545e4d625681cd08476de8fbb8d907bb0 /Transceiver52M/device/Makefile.am
parentfc73c073a127c702e2513c2983871a8970879845 (diff)
smpl_buf: Move it to device/common and create libdevice_common.la
Since in next commit osmo-trx-lms starts using smpl_buf.cpp, it seems some automake step doesn't like including a cpp file twice from a different directory, since race conditions can occur building it. Instead we define the dependency by first building a static lib and then using it on each libdevice.la (one per device type). We already do the similar under arch/ subdir, where we have a common/ subdir and then one subdir and lib per architecture. Change-Id: I465ad0f6d5569bb3006d711c8fd0df14391fcf35
Diffstat (limited to 'Transceiver52M/device/Makefile.am')
-rw-r--r--Transceiver52M/device/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Transceiver52M/device/Makefile.am b/Transceiver52M/device/Makefile.am
index e653a9e..369e877 100644
--- a/Transceiver52M/device/Makefile.am
+++ b/Transceiver52M/device/Makefile.am
@@ -1,8 +1,6 @@
include $(top_srcdir)/Makefile.common
-noinst_HEADERS = radioDevice.h smpl_buf.h
-
-SUBDIRS =
+SUBDIRS = common
if DEVICE_USRP1
SUBDIRS += usrp1