aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/arm/Makefile.am
diff options
context:
space:
mode:
authorThomas Tsou <tom@tsou.cc>2013-11-09 02:29:55 -0500
committerThomas Tsou <tom@tsou.cc>2013-11-15 23:34:59 -0500
commit0a3dc4c21028f36f02528c9a486de229f786b272 (patch)
tree86770439e6accc183d3f04c9e3f46f7e5b4d866c /Transceiver52M/arm/Makefile.am
parentacc22fa3ffe30f28d62c41f62152b1f48fa595b4 (diff)
Transceiver52M: Add NEON complex-complex multiply
Complex-complex block multiples are used for phase rotation of bursts. Optimization targeted from perf profiling. Signed-off-by: Thomas Tsou <tom@tsou.cc>
Diffstat (limited to 'Transceiver52M/arm/Makefile.am')
-rw-r--r--Transceiver52M/arm/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Transceiver52M/arm/Makefile.am b/Transceiver52M/arm/Makefile.am
index 6d34daa..0b959be 100644
--- a/Transceiver52M/arm/Makefile.am
+++ b/Transceiver52M/arm/Makefile.am
@@ -17,5 +17,7 @@ libarch_la_SOURCES = \
convolve.c \
convolve_neon.S \
scale.c \
- scale_neon.S
+ scale_neon.S \
+ mult.c \
+ mult_neon.S
endif