aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
authorkurtis.heimerl <kurtis.heimerl@19bc5d8c-e614-43d4-8b26-e1612bc8e597>2011-11-26 03:18:30 +0000
committerkurtis.heimerl <kurtis.heimerl@19bc5d8c-e614-43d4-8b26-e1612bc8e597>2011-11-26 03:18:30 +0000
commit8aea56e15f3593e3606594fd2e55b3b0022e7c01 (patch)
tree2cc2ceed239223a8e074e5942ca6668e8c5731fc /Transceiver52M/Makefile.am
parent119ca9ca07adc03f3144c84039cfcf16555af865 (diff)
transceiver: separate radio clock and vector interfaces
Remove radio clock and vector interfaces into their own files. This clears up and simplifies the radio interface and, additionaly, prepares for a further split of the I/O portion for optional resampler use. Signed-off-by: Thomas Tsou <ttsou@vt.edu> git-svn-id: http://wush.net/svn/range/software/public/openbts/trunk@2669 19bc5d8c-e614-43d4-8b26-e1612bc8e597
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index 4669b99..5bad45e 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -36,13 +36,18 @@ EXTRA_DIST = \
noinst_LTLIBRARIES = libtransceiver.la
-libtransceiver_la_SOURCES = \
+COMMON_SOURCES = \
radioInterface.cpp \
+ radioVector.cpp \
+ radioClock.cpp \
sigProcLib.cpp \
Transceiver.cpp \
USRPDevice.cpp \
DummyLoad.cpp
+libtransceiver_la_SOURCES = \
+ $(COMMON_SOURCES)
+
noinst_PROGRAMS = \
USRPping \
transceiver \
@@ -51,6 +56,8 @@ noinst_PROGRAMS = \
noinst_HEADERS = \
Complex.h \
radioInterface.h \
+ radioVector.h \
+ radioClock.h \
radioDevice.h \
sigProcLib.h \
Transceiver.h \