aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-02-20 16:48:15 +0100
committerHarald Welte <laforge@gnumonks.org>2018-02-27 07:10:50 +0000
commit5ea1817dc299611808532eda489981f09f87cba3 (patch)
treee92846654f2071526d08112dc4abb55dcd397340 /Transceiver52M/Makefile.am
parent49d42e979eb08cef124e8ceab7d402bed204c015 (diff)
Add initial support for logging, vty, ctrl
Up to this point, the logging system, vty and ctrl are initialized and can be used fine, though they don't have a lot of use yet. Depends on libosmocore Change-Id Ib79cdb62d45d8c78445c7b064e58eb7e9faeccf9 Related: OS#2184 Change-Id: I08982c37b4f873966304b3cfb38a10ee86eb3dad
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index 21104dc..3c1b86c 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -22,7 +22,7 @@
include $(top_srcdir)/Makefile.common
AM_CPPFLAGS = -Wall $(STD_DEFINES_AND_INCLUDES) -I${srcdir}/common
-AM_CXXFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS)
+AM_CXXFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOVTY_CFLAGS)
SUBDIRS = arm x86
@@ -93,7 +93,9 @@ osmo_trx_LDADD = \
$(GSM_LA) \
$(COMMON_LA) \
$(FFTWF_LIBS) \
- $(LIBOSMOCORE_LIBS)
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOCTRL_LIBS) \
+ $(LIBOSMOVTY_LIBS)
if USRP1
libtransceiver_la_SOURCES += USRPDevice.cpp