aboutsummaryrefslogtreecommitdiffstats
path: root/CommonLibs/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-01-09 17:44:49 +0100
committerPau Espin Pedrol <pespin@sysmocom.de>2018-01-10 11:17:32 +0100
commit2ac788b2c32e568260c192e2501c0d4d65a54fcc (patch)
treee98306e298742c8d6f2e9107f1fe6de7b6ce4b4d /CommonLibs/Makefile.am
parentd36ef2f57bd31d528d7dd93048706630fc992b0b (diff)
Set up GNU Autotest infrastructure
Test files are moved from CommonLibs/ to tests/CommonLibs/. Some tests are disabled in autotest because they generate timedate related output which cannot exactly match against expected output. Change-Id: I3d6ba625968be09297642d18090c496490e9b8fc
Diffstat (limited to 'CommonLibs/Makefile.am')
-rw-r--r--CommonLibs/Makefile.am38
1 files changed, 0 insertions, 38 deletions
diff --git a/CommonLibs/Makefile.am b/CommonLibs/Makefile.am
index d42e82a..46cc143 100644
--- a/CommonLibs/Makefile.am
+++ b/CommonLibs/Makefile.am
@@ -38,17 +38,6 @@ libcommon_la_SOURCES = \
Timeval.cpp \
Logger.cpp
-noinst_PROGRAMS = \
- BitVectorTest \
- PRBSTest \
- InterthreadTest \
- SocketsTest \
- TimevalTest \
- VectorTest \
- LogTest
-
-# ReportingTest
-
noinst_HEADERS = \
BitVector.h \
PRBS.h \
@@ -59,30 +48,3 @@ noinst_HEADERS = \
Timeval.h \
Vector.h \
Logger.h
-
-BitVectorTest_SOURCES = BitVectorTest.cpp
-BitVectorTest_LDADD = libcommon.la
-
-PRBSTest_SOURCES = PRBSTest.cpp
-
-InterthreadTest_SOURCES = InterthreadTest.cpp
-InterthreadTest_LDADD = libcommon.la
-InterthreadTest_LDFLAGS = -lpthread
-
-SocketsTest_SOURCES = SocketsTest.cpp
-SocketsTest_LDADD = libcommon.la
-SocketsTest_LDFLAGS = -lpthread
-
-TimevalTest_SOURCES = TimevalTest.cpp
-TimevalTest_LDADD = libcommon.la
-
-VectorTest_SOURCES = VectorTest.cpp
-VectorTest_LDADD = libcommon.la
-
-# ReportingTest_SOURCES = ReportingTest.cpp
-# ReportingTest_LDADD = libcommon.la
-
-LogTest_SOURCES = LogTest.cpp
-LogTest_LDADD = libcommon.la
-
-MOSTLYCLEANFILES += testSource testDestination