aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorYves Godin <support@nuranwireless.com>2016-05-19 11:08:03 +0200
committerHolger Freyther <holger@freyther.de>2016-05-20 16:26:20 +0000
commit660709dc7cfd6a42088988122d65ae8dfadd009c (patch)
tree4b4c5142909e3ac97e30f58310217b405af2e86e /src/Makefile.am
parent58b664675013b948a37ce151948cabe9fe17d386 (diff)
Add support for NuRAN Wireless Litecell 1.5 BTS
Layer 1 compatibility with previous generation or NuRan GSM product, therefore the support for the Litecell 1.5 uses its own sources instead of using tons of ifdef/endif. Max's amendments: * make headers path configurable * use configured TRX instead of hardcoded value * split subdir-objects into separate commit * cosmetic changes Change-Id: Ib1287375cb10a889625bbac8528fa60deed23a2b Fixes: SYS#2443 Reviewed-on: https://gerrit.osmocom.org/61 Tested-by: Jenkins Builder Reviewed-by: Harald Welte <laforge@gnumonks.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e08ba07f..9bdec2f8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,6 +25,10 @@ if ENABLE_SYSMODSP
AM_CPPFLAGS += -DENABLE_DIRECT_PHY
endif
+if ENABLE_LC15BTS_PHY
+AM_CPPFLAGS += -DENABLE_DIRECT_PHY
+endif
+
AM_CXXFLAGS = -Wall -ldl -pthread
AM_LDFLAGS = -lrt
@@ -130,6 +134,26 @@ osmo_pcu_remote_LDADD = \
$(COMMON_LA)
endif
+if ENABLE_LC15BTS_PHY
+AM_CPPFLAGS += -I$(LITECELL15_INCDIR) -I$(srcdir)/osmo-bts-litecell15
+
+EXTRA_DIST = \
+ osmo-bts-litecell15/lc15_l1_if.c \
+ osmo-bts-litecell15/lc15_l1_if.h \
+ osmo-bts-litecell15/lc15_l1_hw.c \
+ osmo-bts-litecell15/lc15bts.c \
+ osmo-bts-litecell15/lc15bts.h
+
+noinst_HEADERS += \
+ osmo-bts-litecell15/lc15_l1_if.h \
+ osmo-bts-litecell15/lc15bts.h
+
+osmo_pcu_SOURCES += \
+ osmo-bts-litecell15/lc15_l1_if.c \
+ osmo-bts-litecell15/lc15_l1_hw.c \
+ osmo-bts-litecell15/lc15bts.c
+endif
+
osmo_pcu_LDADD = \
libgprs.la \
$(LIBOSMOGB_LIBS) \