aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2015-07-20 12:40:42 +0200
committerJacob Erlbeck <jerlbeck@sysmocom.de>2015-07-21 19:22:32 +0200
commit4f666bc1136eb581d11dc47741928725c76b09c6 (patch)
treeed787c651337acc0324385da373cc58cee441cb1 /src/Makefile.am
parent7f79f0d332316acb306682ecac0a1b812d6023d1 (diff)
llc: Add CoDel AQM implementation
This commit adds an implementation of the CoDel algorithm based on the reference pseudocode presented in http://queue.acm.org/appendices/codel.html. Instead of abstracting the queue itself, the implementation provides a time stamp based automaton which is invoked after a package has been dequeued. Note that the modifications of the algorithm shown in https://tools.ietf.org/html/draft-ietf-aqm-codel-01 are not yet applied. Sponsored-by: On-Waves ehf
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a63281fa..35874164 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -54,7 +54,8 @@ libgprs_la_SOURCES = \
sba.cpp \
decoding.cpp \
llc.cpp \
- rlc.cpp
+ rlc.cpp \
+ gprs_codel.c
if ENABLE_SYSMOBTS
libgprs_la_SOURCES += \
@@ -99,7 +100,8 @@ noinst_HEADERS = \
decoding.h \
llc.h \
pcu_utils.h \
- cxx_linuxlist.h
+ cxx_linuxlist.h \
+ gprs_codel.h
osmo_pcu_SOURCES = pcu_main.cpp