aboutsummaryrefslogtreecommitdiffstats
path: root/src/sabp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/sabp/Makefile.am')
-rw-r--r--src/sabp/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/sabp/Makefile.am b/src/sabp/Makefile.am
index 0665db4..8dc1390 100644
--- a/src/sabp/Makefile.am
+++ b/src/sabp/Makefile.am
@@ -135,7 +135,14 @@ libosmo_asn1_sabp_la_LIBADD=$(ASN1C_LDADD)
regen: regenerate-from-asn1-source
regenerate-from-asn1-source:
- ASN1C_PREFIX="SABP_" asn1c -R -fcompound-names -gen-PER $(top_srcdir)/asn1/sabp/SABP-CommonDataTypes.asn $(top_srcdir)/asn1/sabp/SABP-Constants.asn $(top_srcdir)/asn1/sabp/SABP-IEs.asn $(top_srcdir)/asn1/sabp/SABP-PDU.asn
+ ASN1C_PREFIX="SABP_" asn1c \
+ -R \
+ -fcompound-names \
+ -gen-PER \
+ $(top_srcdir)/asn1/sabp/SABP-CommonDataTypes.asn \
+ $(top_srcdir)/asn1/sabp/SABP-Constants.asn \
+ $(top_srcdir)/asn1/sabp/SABP-IEs.asn \
+ $(top_srcdir)/asn1/sabp/SABP-PDU.asn
# add missing includes
sed -i '/#include "SABP_Serial-Number.h"/a #include <constr_CHOICE.h>' SABP_Old-Serial-Number.h SABP_New-Serial-Number.h
# change include style to `#include <dir/foo.h>'