aboutsummaryrefslogtreecommitdiffstats
path: root/src/hnbap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hnbap/Makefile.am')
-rw-r--r--src/hnbap/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/hnbap/Makefile.am b/src/hnbap/Makefile.am
index 15bee55..ca1df17 100644
--- a/src/hnbap/Makefile.am
+++ b/src/hnbap/Makefile.am
@@ -243,7 +243,14 @@ libosmo_asn1_hnbap_la_LIBADD=$(ASN1C_LDADD)
regen: regenerate-from-asn1-source
regenerate-from-asn1-source:
- ASN1C_PREFIX="HNBAP_" asn1c -R -fcompound-names -gen-PER $(HNBAP_ASN1)/HNBAP-CommonDataTypes.asn $(HNBAP_ASN1)/HNBAP-Constants.asn $(HNBAP_ASN1)/HNBAP-IEs.asn $(HNBAP_ASN1)/HNBAP-PDU.asn
+ ASN1C_PREFIX="HNBAP_" asn1c \
+ -R \
+ -fcompound-names \
+ -gen-PER \
+ $(HNBAP_ASN1)/HNBAP-CommonDataTypes.asn \
+ $(HNBAP_ASN1)/HNBAP-Constants.asn \
+ $(HNBAP_ASN1)/HNBAP-IEs.asn \
+ $(HNBAP_ASN1)/HNBAP-PDU.asn
# change include style to `#include <dir/foo.h>'
$(top_srcdir)/move-asn1-header-files.sh osmocom/hnbap $(ASN_MODULE_INC)
# Finally copy *.c from buildir to srcdir: