aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..40dad90
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,16 @@
+AUTOMAKE_OPTIONS = foreign dist-bzip2
+
+SUBDIRS = \
+ src \
+ sql \
+ $(NULL)
+
+EXTRA_DIST = \
+ .version \
+ $(NULL)
+
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version