aboutsummaryrefslogtreecommitdiffstats
path: root/src/osmo-bsc/Makefile.am
diff options
context:
space:
mode:
authorPhilipp Maier <pmaier@sysmocom.de>2017-09-27 15:51:34 +0200
committerHarald Welte <laforge@gnumonks.org>2017-11-07 20:57:51 +0000
commit39c609b7c924524172ad311bdf89f92b7ccf175a (patch)
tree23de9db3438dfcaf88ad27f082dbbf0dea140769 /src/osmo-bsc/Makefile.am
parent9eb208fcfb75eedd2b1a45a2aa67893ce4726404 (diff)
mgcp: use osmo-mgw to switch RTP streams
osmo-bsc currently negotiates the RTP stream directly with the BTS and reports back the RTP IP/Port on the BTS. This works fine for a single BTS, but for Handover the port/ip pointing to the MSC side must not change, so an entity in between the BTSs and the MSC is required. Integrate the mgcp-client and use osmo-mgw to switch the RTP streams. Depends: osmo-mgw Ib5fcc72775bf72b489ff79ade36fb345d8d20736 Depends: osmo-mgw I44b338b09de45e1675cedf9737fa72dde72e979a Depends: osmo-mgw I29c5e2fb972896faeb771ba040f015592487fcbe Change-Id: Ia2882b7ca31a3219c676986e85045fa08a425d7a
Diffstat (limited to 'src/osmo-bsc/Makefile.am')
-rw-r--r--src/osmo-bsc/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/osmo-bsc/Makefile.am b/src/osmo-bsc/Makefile.am
index dfc4defcb..7db698c1d 100644
--- a/src/osmo-bsc/Makefile.am
+++ b/src/osmo-bsc/Makefile.am
@@ -15,6 +15,7 @@ AM_CFLAGS = \
$(COVERAGE_CFLAGS) \
$(LIBOSMOABIS_CFLAGS) \
$(LIBOSMOSIGTRAN_CFLAGS) \
+ $(LIBOSMOMGCPCLIENT_CFLAGS) \
$(NULL)
AM_LDFLAGS = \
@@ -30,6 +31,7 @@ osmo_bsc_SOURCES = \
osmo_bsc_vty.c \
osmo_bsc_api.c \
osmo_bsc_grace.c \
+ osmo_bsc_mgcp.c \
osmo_bsc_msc.c \
osmo_bsc_sigtran.c \
osmo_bsc_filter.c \
@@ -53,4 +55,5 @@ osmo_bsc_LDADD = \
$(COVERAGE_LDFLAGS) \
$(LIBOSMOABIS_LIBS) \
$(LIBOSMOSIGTRAN_LIBS) \
+ $(LIBOSMOMGCPCLIENT_LIBS) \
$(NULL)