aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2023-07-11 11:43:30 +0200
committerOliver Smith <osmith@sysmocom.de>2023-07-11 12:48:28 +0200
commit3dc3ca5bab2804eb7755d540597e2687330fa6b5 (patch)
tree0c3598391c5b8386be0e95ae319fc9604d5905fb /debian
parent79b683ec24288cd559c812eb8109a8349179f099 (diff)
Cosmetic: debian/rules: remove boilerplate
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules47
1 files changed, 0 insertions, 47 deletions
diff --git a/debian/rules b/debian/rules
index a6646c10b..e6834c30d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,57 +1,10 @@
#!/usr/bin/make -f
-# You must remove unused comment lines for the released package.
-# See debhelper(7) (uncomment to enable)
-# This is an autogenerated template for debian/rules.
-#
-# Output every command that modifies files on the build system.
-#export DH_VERBOSE = 1
-#
-# Copy some variable definitions from pkg-info.mk and vendor.mk
-# under /usr/share/dpkg/ to here if they are useful.
-#
-# See FEATURE AREAS/ENVIRONMENT in dpkg-buildflags(1)
-# Apply all hardening options
-#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-# Package maintainers to append CFLAGS
-#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
-# Package maintainers to append LDFLAGS
-#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
-#
-# With debhelper version 9 or newer, the dh command exports
-# all buildflags. So there is no need to include the
-# /usr/share/dpkg/buildflags.mk file here if compat is 9 or newer.
-#
-# These are rarely used code. (START)
-#
-# The following include for *.mk magically sets miscellaneous
-# variables while honoring existing values of pertinent
-# environment variables:
-#
-# Architecture-related variables such as DEB_TARGET_MULTIARCH:
-#include /usr/share/dpkg/architecture.mk
-# Vendor-related variables such as DEB_VENDOR:
-#include /usr/share/dpkg/vendor.mk
-# Package-related variables such as DEB_DISTRIBUTION
-#include /usr/share/dpkg/pkg-info.mk
-#
-# You may alternatively set them susing a simple script such as:
-# DEB_VENDOR ?= $(shell dpkg-vendor --query Vendor)
-#
-# These are rarely used code. (END)
-#
-
-# main packaging script based on dh7 syntax
%:
dh $@ --with autoreconf
-# debmake generated override targets
CONFIGURE_FLAGS += --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
override_dh_auto_configure:
dh_auto_configure -- $(CONFIGURE_FLAGS)
-#
-# Do not install libtool archive, python .pyc .pyo
-#override_dh_install:
-# dh_install --list-missing -X.la -X.pyc -X.pyo
# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
override_dh_strip: