aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/sgsn/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2015-01-09 15:07:16 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-01-18 18:28:20 +0100
commitc157ee7d2ccdb7524e76d25b22cb7eec8de9a656 (patch)
treefdfe6e7de20a9c35163077efe0723e740b18e782 /openbsc/tests/sgsn/Makefile.am
parent0f47b8fae743769a6627f8654444b4f0d665e050 (diff)
sgsn/test: Add test that intercepts gprs_gsup_client_send
This test replaces gprs_gsup_client_send by a custom function, that emulates a GSUP remote peer by calling gprs_subscr_rx_gsup_message with responses for all requests. It then executes a full Attach/Detach cycle. Sponsored-by: On-Waves ehf
Diffstat (limited to 'openbsc/tests/sgsn/Makefile.am')
-rw-r--r--openbsc/tests/sgsn/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/openbsc/tests/sgsn/Makefile.am b/openbsc/tests/sgsn/Makefile.am
index 672b811bb..c1b5fbda4 100644
--- a/openbsc/tests/sgsn/Makefile.am
+++ b/openbsc/tests/sgsn/Makefile.am
@@ -9,7 +9,8 @@ sgsn_test_SOURCES = sgsn_test.c
sgsn_test_LDFLAGS = \
-Wl,--wrap=sgsn_update_subscriber_data \
-Wl,--wrap=gprs_subscr_request_update_location \
- -Wl,--wrap=gprs_subscr_request_auth_info
+ -Wl,--wrap=gprs_subscr_request_auth_info \
+ -Wl,--wrap=gprs_gsup_client_send
sgsn_test_LDADD = \
$(top_builddir)/src/gprs/gprs_llc_parse.o \