aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/mgcp/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2014-04-08 16:10:04 +0200
committerJacob Erlbeck <jerlbeck@sysmocom.de>2014-06-05 14:08:53 +0200
commit84a45cbf8384be753e2b83414dddc95ad63f4f2b (patch)
tree12c7ba15d70483a095b3d40fec2fb4d1c3e33566 /openbsc/tests/mgcp/Makefile.am
parent07886d9b0abe81259433ab39a8a8fc86e1c197a3 (diff)
mgcp/test: Add test cases for transcoding and repacking
This patch adds test cases for transcoding and repacking. Sponsored-by: On-Waves ehf
Diffstat (limited to 'openbsc/tests/mgcp/Makefile.am')
-rw-r--r--openbsc/tests/mgcp/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/openbsc/tests/mgcp/Makefile.am b/openbsc/tests/mgcp/Makefile.am
index 79e0bf49d..3982b0782 100644
--- a/openbsc/tests/mgcp/Makefile.am
+++ b/openbsc/tests/mgcp/Makefile.am
@@ -1,11 +1,15 @@
-AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
-AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS) $(LIBOSMOSCCP_CFLAGS) $(COVERAGE_CFLAGS)
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_srcdir)
+AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS) $(LIBOSMOSCCP_CFLAGS) $(COVERAGE_CFLAGS) $(LIBBCG729_CFLAGS)
AM_LDFLAGS = $(COVERAGE_LDFLAGS)
-EXTRA_DIST = mgcp_test.ok
+EXTRA_DIST = mgcp_test.ok mgcp_transcoding_test.ok
noinst_PROGRAMS = mgcp_test
+if BUILD_MGCP_TRANSCODING
+noinst_PROGRAMS += mgcp_transcoding_test
+endif
+
mgcp_test_SOURCES = mgcp_test.c
mgcp_test_LDADD = $(top_builddir)/src/libbsc/libbsc.a \
@@ -13,3 +17,12 @@ mgcp_test_LDADD = $(top_builddir)/src/libbsc/libbsc.a \
$(top_builddir)/src/libcommon/libcommon.a \
$(LIBOSMOCORE_LIBS) -lrt -lm $(LIBOSMOSCCP_LIBS) $(LIBOSMOVTY_LIBS) \
$(LIBRARY_DL) $(LIBOSMONETIF_LIBS)
+
+mgcp_transcoding_test_SOURCES = mgcp_transcoding_test.c $(top_builddir)/src/osmo-bsc_mgcp/mgcp_transcode.c
+
+mgcp_transcoding_test_LDADD = \
+ $(top_builddir)/src/libbsc/libbsc.a \
+ $(top_builddir)/src/libmgcp/libmgcp.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) $(LIBBCG729_LIBS) -lrt -lm $(LIBOSMOSCCP_LIBS) $(LIBOSMOVTY_LIBS) \
+ $(LIBRARY_DL) $(LIBOSMONETIF_LIBS)