aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/gtphub/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-10-25 22:31:59 +0200
committerHarald Welte <laforge@gnumonks.org>2017-10-26 00:06:40 +0200
commited03661871ac8ee1715c04390d25631537b084ac (patch)
tree39aeda51387ba5af9ebd44a552163fa0d0345e52 /openbsc/tests/gtphub/Makefile.am
parent888e35aa7fbb2ba40526456abab739b7c15013e0 (diff)
remove sgsn, gbproxy and gtphub from openbsc.git
The GPRS related programs osmo-sgsn, osmo-gtphub and osmo-gbproxy have been split off into the separate osmo-sgsn repository, which can be found at git://git.osmocom.org/osmo-sgsn.git http://git.osmocom.org/osmo-sgsn/ This is technically unrelated but conceptually part of the larger NITB-split activities. I did a brief log of all changes in src/gprs and couldn't find any commits that we might have applied here but which are missing from osmo-sgsn.git. Change-Id: If60e28b23f5cfb2c4eb354951363a2bb63f3e0de
Diffstat (limited to 'openbsc/tests/gtphub/Makefile.am')
-rw-r--r--openbsc/tests/gtphub/Makefile.am44
1 files changed, 0 insertions, 44 deletions
diff --git a/openbsc/tests/gtphub/Makefile.am b/openbsc/tests/gtphub/Makefile.am
deleted file mode 100644
index f2a6b888e..000000000
--- a/openbsc/tests/gtphub/Makefile.am
+++ /dev/null
@@ -1,44 +0,0 @@
-AM_CPPFLAGS = \
- $(all_includes) \
- -I$(top_srcdir)/include \
- $(NULL)
-
-AM_CFLAGS = \
- -Wall \
- -ggdb3 \
- $(LIBOSMOCORE_CFLAGS) \
- $(LIBOSMOABIS_CFLAGS) \
- $(LIBOSMOGSM_CFLAGS) \
- $(LIBGTP_CFLAGS) \
- $(NULL)
-
-EXTRA_DIST = \
- gtphub_test.ok \
- $(NULL)
-
-if HAVE_LIBGTP
-if HAVE_LIBCARES
-noinst_PROGRAMS = \
- gtphub_test \
- $(NULL)
-endif
-endif
-
-gtphub_test_SOURCES = \
- gtphub_test.c \
- $(NULL)
-
-gtphub_test_LDFLAGS = \
- -Wl,--wrap=gtphub_resolve_ggsn_addr \
- -Wl,--wrap=gtphub_ares_init \
- -Wl,--wrap=gtphub_write \
- $(NULL)
-
-gtphub_test_LDADD = \
- $(top_builddir)/src/gprs/gtphub.o \
- $(top_builddir)/src/gprs/gprs_utils.o \
- $(LIBOSMOCORE_LIBS) \
- $(LIBOSMOGSM_LIBS) \
- $(LIBGTP_LIBS) \
- -lrt \
- $(NULL)