aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/bsc-nat/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-30 05:57:42 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-06-15 20:24:09 +0800
commitbae9da49b9e9bf05d8f105b00ea2008b657dacce (patch)
treedcdebfdd4297268500dfc8ad39604a5f16e5390d /openbsc/tests/bsc-nat/Makefile.am
parent38f7c7573984c51a33f756b775537b65841cb650 (diff)
nat: Move paging by lac handling code into the utils file
Moving it here means we can more easily test this code, there is one behaviour change with the code that we only support paging messages with one LAC and will silently ignore the others.
Diffstat (limited to 'openbsc/tests/bsc-nat/Makefile.am')
-rw-r--r--openbsc/tests/bsc-nat/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/openbsc/tests/bsc-nat/Makefile.am b/openbsc/tests/bsc-nat/Makefile.am
index f0d21f01f..d26bbeb47 100644
--- a/openbsc/tests/bsc-nat/Makefile.am
+++ b/openbsc/tests/bsc-nat/Makefile.am
@@ -8,5 +8,6 @@ noinst_PROGRAMS = bsc_nat_test
bsc_nat_test_SOURCES = bsc_nat_test.c \
$(top_srcdir)/src/nat/bsc_filter.c \
$(top_srcdir)/src/nat/bsc_sccp.c \
- $(top_srcdir)/src/nat/bsc_nat_utils.c
+ $(top_srcdir)/src/nat/bsc_nat_utils.c \
+ $(top_srcdir)/src/bssap.c
bsc_nat_test_LDADD = $(top_builddir)/src/libbsc.a $(top_builddir)/src/libsccp.a $(LIBOSMOCORE_LIBS)