aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/gprs/Makefile.am
diff options
context:
space:
mode:
authorPhilipp <pmaier@sysmocom.de>2016-08-10 12:08:03 +0200
committerHarald Welte <laforge@gnumonks.org>2016-09-24 03:17:58 +0000
commit22611be3d93b58ba96983247d71fa6be57fa0cb0 (patch)
treed3cf6edb86ad200de2689eabc45b6f70afa38264 /openbsc/src/gprs/Makefile.am
parent308cb0719dca3ba8eed1eff2a2124d44f34d9a28 (diff)
SNDCP: add SNDCP-XID encoder/decoder and unit test
The SNDCP-XID (or layer-3 xid) is used to exchange layer-3 parameters such as compression. The encoder encodes a bytestream that is then sent as regular XID field from LLC. We will need the SNDCP-XID to negotiate the parameters for our upcomming GPRS data and header compression features Change-Id: If2d63fe2550864cafef3156b1dc0629037c49c1e
Diffstat (limited to 'openbsc/src/gprs/Makefile.am')
-rw-r--r--openbsc/src/gprs/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/openbsc/src/gprs/Makefile.am b/openbsc/src/gprs/Makefile.am
index 59136bd32..3b5839997 100644
--- a/openbsc/src/gprs/Makefile.am
+++ b/openbsc/src/gprs/Makefile.am
@@ -72,6 +72,7 @@ osmo_sgsn_SOURCES = \
gprs_sgsn.c \
gprs_sndcp.c \
gprs_sndcp_vty.c \
+ gprs_sndcp_xid.c \
sgsn_main.c \
sgsn_vty.c \
sgsn_libgtp.c \
@@ -98,6 +99,7 @@ osmo_sgsn_LDADD = \
$(LIBCRYPTO_LIBS) \
-lrt \
-lgtp \
+ -lm \
$(NULL)
if BUILD_IU
osmo_sgsn_LDADD += \