aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-osmocom
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2013-03-24 09:07:25 +0100
committerHarald Welte <laforge@gnumonks.org>2013-03-24 09:07:25 +0100
commit558d76a4123fb7e3689ebc30f9d58e3ec1fae043 (patch)
tree1d55ee6f109776e3cd13967bd4b39bcd2696c317 /recipes-osmocom
parent3a01a4f2bc8e3e4cd4e52396767741aa4a062bba (diff)
openggsn: Add patch to reduce queue depth / memory usage
Diffstat (limited to 'recipes-osmocom')
-rw-r--r--recipes-osmocom/openggsn/files/libgtp-queue_depth_32.patch13
-rw-r--r--recipes-osmocom/openggsn/openggsn_git.bb3
2 files changed, 15 insertions, 1 deletions
diff --git a/recipes-osmocom/openggsn/files/libgtp-queue_depth_32.patch b/recipes-osmocom/openggsn/files/libgtp-queue_depth_32.patch
new file mode 100644
index 0000000..52bc37b
--- /dev/null
+++ b/recipes-osmocom/openggsn/files/libgtp-queue_depth_32.patch
@@ -0,0 +1,13 @@
+diff --git a/gtp/queue.h b/gtp/queue.h
+index 556b6ef..d59a1a3 100644
+--- a/gtp/queue.h
++++ b/gtp/queue.h
+@@ -19,7 +19,7 @@
+
+ #define QUEUE_DEBUG 0 /* Print debug information */
+
+-#define QUEUE_SIZE 1024 /* Size of retransmission queue */
++#define QUEUE_SIZE 32 /* Size of retransmission queue */
+ #define QUEUE_HASH_SIZE 65536 /* Size of hash table (2^16) */
+
+ struct qmsg_t { /* Holder for queued packets */
diff --git a/recipes-osmocom/openggsn/openggsn_git.bb b/recipes-osmocom/openggsn/openggsn_git.bb
index 8aaaf8d..ebcfee6 100644
--- a/recipes-osmocom/openggsn/openggsn_git.bb
+++ b/recipes-osmocom/openggsn/openggsn_git.bb
@@ -2,11 +2,12 @@ DESCRITOPN = "OpenGGSN a Free Software GGSN"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
PV = "0.91+gitr${SRCPV}"
-PR = "r11"
+PR = "r12"
SRCREV = "95848bafcef145d776d70a73f7bdc3fe37e85724"
SRC_URI = "git://ggsn.git.sourceforge.net/gitroot/ggsn/ggsn \
file://openggsn.init \
+ file://libgtp-queue_depth_32.patch \
"
S = "${WORKDIR}/git"