aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-isdn
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@freyther.de>2012-07-21 23:46:45 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-07-21 18:05:25 +0200
commitf4320dd67f9681e24bcfbe112832cac2ceacebd0 (patch)
treee265e0e99880992350523c87a92f5f399330a80e /recipes-isdn
parent1f717355169d3ea3c1065582d8c30ad5e643c457 (diff)
dahdi-tools: Build dahdi_pcap and fix the installation of the perl modules
Diffstat (limited to 'recipes-isdn')
-rw-r--r--recipes-isdn/dahdi-tools/dahdi-tools.inc27
-rw-r--r--recipes-isdn/dahdi-tools/dahdi-tools_2.6.0.bb2
-rwxr-xr-xrecipes-isdn/dahdi-tools/files/perl_install.patch13
3 files changed, 37 insertions, 5 deletions
diff --git a/recipes-isdn/dahdi-tools/dahdi-tools.inc b/recipes-isdn/dahdi-tools/dahdi-tools.inc
index 6d0f462..61280ea 100644
--- a/recipes-isdn/dahdi-tools/dahdi-tools.inc
+++ b/recipes-isdn/dahdi-tools/dahdi-tools.inc
@@ -1,17 +1,36 @@
DESCRITOPN = "Utilities for the DAHDI Asterisk Linux kernel drivers"
-DEPENDS = "dahdi-linux libnewt"
+DEPENDS = "dahdi-linux libnewt libpcap"
+RDEPENDS += "perl perl-module-strict perl-module-file-basename perl-module-config \
+ perl-module-warnings perl-module-getopt perl-module-getopt-std \
+ perl-module-file perl-module-file-glob perl-module-xsloader \
+ perl-module-dynaloader perl-module-carp perl-module-errno"
+
HOMEPAGE = "http://www.asterisk.org"
LICENSE = "GPLv2"
-SRC_URI = "http://downloads.asterisk.org/pub/telephony/dahdi-tools/releases/dahdi-tools-${PV}.tar.gz"
+SRC_URI = "http://downloads.asterisk.org/pub/telephony/dahdi-tools/releases/dahdi-tools-${PV}.tar.gz \
+ file://perl_install.patch "
-INC_PR="r2"
+INC_PR="r18"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ea5bed2f60d357618ca161ad539f7c0a \
file://LICENSE.LGPL;md5=fb504b67c50331fc78734fed90fb0e09"
-inherit autotools_stage pkgconfig
+FILES_${PN} += "${datadir}/dahdi"
+
+inherit autotools_stage pkgconfig perlnative cpan-base
do_configure() {
oe_runconf
}
+
+do_compile() {
+ base_do_compile
+ oe_runmake dahdi_pcap
+}
+
+export DAHDI_PERLLIBDIR="${PERLLIBDIRS}/${@get_perl_version(d)}"
+do_install() {
+ autotools_do_install
+ install -m 755 ${S}/dahdi_pcap ${D}${sbindir}/
+}
diff --git a/recipes-isdn/dahdi-tools/dahdi-tools_2.6.0.bb b/recipes-isdn/dahdi-tools/dahdi-tools_2.6.0.bb
index d1e6987..35132e4 100644
--- a/recipes-isdn/dahdi-tools/dahdi-tools_2.6.0.bb
+++ b/recipes-isdn/dahdi-tools/dahdi-tools_2.6.0.bb
@@ -1,4 +1,4 @@
require ${PN}.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
diff --git a/recipes-isdn/dahdi-tools/files/perl_install.patch b/recipes-isdn/dahdi-tools/files/perl_install.patch
new file mode 100755
index 0000000..adcda2b
--- /dev/null
+++ b/recipes-isdn/dahdi-tools/files/perl_install.patch
@@ -0,0 +1,13 @@
+Index: dahdi-tools-2.6.0/xpp/Makefile
+===================================================================
+--- dahdi-tools-2.6.0.orig/xpp/Makefile 2011-07-11 00:25:18.000000000 +0800
++++ dahdi-tools-2.6.0/xpp/Makefile 2012-07-21 23:30:58.244897984 +0800
+@@ -28,7 +28,7 @@
+ DATADIR = $(datadir)/dahdi
+ MANDIR = $(mandir)/man8
+ HOTPLUG_USB_DIR = $(sysconfdir)/hotplug/usb
+-PERLLIBDIR := $(shell eval `perl -V:sitelib`; echo "$$sitelib")
++PERLLIBDIR = $(DAHDI_PERLLIBDIR)
+ PERL_DIRS := $(shell cd perl_modules; find * -name '[A-Z]*' -type d| xargs)
+ PERL_MODS_PAT := *.pm $(PERL_DIRS:%=%/*.pm)
+ PERL_MODS := $(shell cd perl_modules; echo $(PERL_MODS_PAT))