aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2020-09-18 18:00:50 +0200
committerNeels Hofmeyr <neels@hofmeyr.de>2020-10-07 15:19:43 +0200
commitc6848f41455068a3bb59ca937293d2c0da0af14d (patch)
tree395339bc1d2d68cf7202f45ac9c69f961fdba94c /tests/Makefile.am
parent086bd33f18fa79eb239a06e404915f3ba3c20e3f (diff)
add BSSLAP coding for Location Services
BSSLAP: there are APDUs transferred in BSSMAP-LE Connection Oriented Information messages on Lb between BSC and SMLC. Add BSSLAP coding for these APDU messages: - TA Layer3 - TA Request - TA Response, possibly containing Location Estimate coded in GAD - Reject - Reset (for intra-BSS handover during TA Request) - Abort (for inter-BSS handover) Add encoding and decoding tests. Change-Id: I6409c4bcac402dc7626a3afce9081c59cd715fe8
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c4e6b9f5..fc994852 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -39,6 +39,7 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
i460_mux/i460_mux_test \
bitgen/bitgen_test \
gad/gad_test \
+ bsslap/bsslap_test \
$(NULL)
if ENABLE_MSGFILE
@@ -285,6 +286,9 @@ bitgen_bitgen_test_LDADD = $(LDADD)
gad_gad_test_SOURCES = gad/gad_test.c
gad_gad_test_LDADD = $(LDADD) $(top_builddir)/src/gsm/gad.o
+bsslap_bsslap_test_SOURCES = bsslap/bsslap_test.c
+bsslap_bsslap_test_LDADD = $(LDADD) $(top_builddir)/src/gsm/libosmogsm.la
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \
@@ -366,6 +370,7 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
i460_mux/i460_mux_test.ok \
bitgen/bitgen_test.ok \
gad/gad_test.ok \
+ bsslap/bsslap_test.ok \
$(NULL)
if ENABLE_LIBSCTP