aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2016-02-05 13:55:38 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2016-02-18 19:45:44 +0100
commit5c18e26bc291766b0de22223abcf340bc48e3157 (patch)
tree8177990abcaed45170179e5d1910f3e8b26e1213 /tests/Makefile.am
parent0a59e9899f4dd4213dc72d535f0b9d5382dc7eb7 (diff)
Add T4 bit map compression routines
Add bit map encoder and decoder functions: decoder is fully functional while encoder is good enough for testing - no backtracking to find the best possible compression is implemented. If somebody is willing to implement MS side of EDGE than this has to be expanded. Add corresponding tests. N. B: the encoding is implemented according to ETSI TS 44.060 which is slightly different from T4 used for fax according to CCITT G31D (RFC 804). Ticket: OW#2407 Sponsored-by: On-Waves ehf Signed-off-by: Max <msuraev@sysmocom.de>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a4a6b2e0..571e87b0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -12,7 +12,7 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
loggingrb/loggingrb_test strrb/strrb_test \
vty/vty_test comp128/comp128_test utils/utils_test \
smscb/gsm0341_test stats/stats_test \
- bitvec/bitvec_test msgb/msgb_test
+ bitvec/bitvec_test msgb/msgb_test bits/bitcomp_test
if ENABLE_MSGFILE
check_PROGRAMS += msgfile/msgfile_test
@@ -42,6 +42,9 @@ bits_bitrev_test_LDADD = $(top_builddir)/src/libosmocore.la
bitvec_bitvec_test_SOURCES = bitvec/bitvec_test.c
bitvec_bitvec_test_LDADD = $(top_builddir)/src/libosmocore.la
+bits_bitcomp_test_SOURCES = bits/bitcomp_test.c
+bits_bitcomp_test_LDADD = $(top_builddir)/src/libosmocore.la
+
conv_conv_test_SOURCES = conv/conv_test.c
conv_conv_test_LDADD = $(top_builddir)/src/libosmocore.la
@@ -136,7 +139,7 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
loggingrb/logging_test.err strrb/strrb_test.ok \
vty/vty_test.ok comp128/comp128_test.ok \
utils/utils_test.ok stats/stats_test.ok \
- bitvec/bitvec_test.ok msgb/msgb_test.ok
+ bitvec/bitvec_test.ok msgb/msgb_test.ok bits/bitcomp_test.ok
DISTCLEANFILES = atconfig