aboutsummaryrefslogtreecommitdiffstats
path: root/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2016-06-30 10:39:00 +0200
committerHarald Welte <laforge@gnumonks.org>2016-07-11 19:15:24 +0000
commit4f169500df996d0a7a804da77bae07b2ecd0d813 (patch)
treea7904447e291f1782837d03e4702543541d10b30 /src/gsm/Makefile.am
parent02a66728856d6a111ef61eca2cc052df052579a9 (diff)
Add GEA3 & GEA4 ciphers
Corresponding test code include both official test vectors from the specs and data from over-the-air tests. This obsoletes libosmo-crypt-a53 as it was last missing piece unimplemented in libosmogsm. Change-Id: I939e4f6b91b4a7c591ef3761fe2d46ed1c2fb2d3 Related: OS#1582
Diffstat (limited to 'src/gsm/Makefile.am')
-rw-r--r--src/gsm/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/gsm/Makefile.am b/src/gsm/Makefile.am
index 781f153a..0f43f48a 100644
--- a/src/gsm/Makefile.am
+++ b/src/gsm/Makefile.am
@@ -24,10 +24,10 @@ libgsmint_la_SOURCES = a5.c rxlev_stat.c tlv_parser.c comp128.c comp128v23.c \
conv_tch_afs_6_7_gen.c conv_tch_afs_5_9_gen.c \
conv_tch_afs_5_15_gen.c conv_tch_afs_4_75_gen.c \
auth_core.c auth_comp128v1.c auth_comp128v23.c \
- auth_milenage.c milenage/aes-encblock.c \
+ auth_milenage.c milenage/aes-encblock.c gea.c \
milenage/aes-internal.c milenage/aes-internal-enc.c \
milenage/milenage.c gan.c ipa.c gsm0341.c apn.c \
- gsup.c
+ gsup.c gprs_gea.c
libgsmint_la_LDFLAGS = -no-undefined
libgsmint_la_LIBADD = ../libosmocore.la