aboutsummaryrefslogtreecommitdiffstats
path: root/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-12-07 00:24:32 +0100
committerHarald Welte <laforge@gnumonks.org>2011-12-07 00:24:32 +0100
commit4b3fbd45aca009ae3000be4e8db4a29cb950bf31 (patch)
tree8e40a23952b89c467a200d237b99ec98b9221ce6 /src/gsm/Makefile.am
parente076ac087cb568ad0748f4d8469e6dcda811d7c8 (diff)
add milenage internal headers to ensure 'make dist' works
Diffstat (limited to 'src/gsm/Makefile.am')
-rw-r--r--src/gsm/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/gsm/Makefile.am b/src/gsm/Makefile.am
index 4b886ed2..46d40a11 100644
--- a/src/gsm/Makefile.am
+++ b/src/gsm/Makefile.am
@@ -5,6 +5,11 @@ LIBVERSION=2:0:1
INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS = -fPIC -Wall
+# FIXME: this should eventually go into a milenage/Makefile.am
+noinst_HEADERS = milenage/aes.h milenage/aes_i.h milenage/aes_wrap.h \
+ milenage/common.h milenage/crypto.h milenage/includes.h \
+ milenage/milenage.h
+
lib_LTLIBRARIES = libosmogsm.la
libosmogsm_la_SOURCES = a5.c rxlev_stat.c tlv_parser.c comp128.c gsm_utils.c \