aboutsummaryrefslogtreecommitdiffstats
path: root/src/codec/Makefile.am
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2010-10-08 15:09:16 +0200
committerSylvain Munaut <tnt@246tNt.com>2010-10-15 09:45:04 +0200
commit1a4ea5b4364b756276da5d378d81e3b15a1d5f84 (patch)
treec8107e215d52618483629ec8536b6d51aa37d46d /src/codec/Makefile.am
parent394635b2e35059109afcf8f939c2e456eed1fdf9 (diff)
codec: Add bit ordering tables from specs for HR,FR,EFR & AMR
Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'src/codec/Makefile.am')
-rw-r--r--src/codec/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/codec/Makefile.am b/src/codec/Makefile.am
new file mode 100644
index 00000000..f8a06012
--- /dev/null
+++ b/src/codec/Makefile.am
@@ -0,0 +1,10 @@
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
+LIBVERSION=0:0:0
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS = -fPIC -Wall
+
+lib_LTLIBRARIES = libosmocodec.la
+
+libosmocodec_la_SOURCES = gsm610.c gsm620.c gsm660.c gsm690.c