aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-05-04 19:21:58 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2018-05-04 19:25:16 +0200
commitcacaa4a1616d7c0ea370ff197d816f706909bde5 (patch)
tree70cae92ad01846cdeda2d0df8a2ecd3992730a0e /src/Makefile.am
parent686eba9bfcdd229bc1e40c75a220cfd379d15b8c (diff)
configure: Check separately for lib implementing dlopen and dlsym
Sometimes the library probiding dlopen is not the same one providing dlsym. This is the case when compiling with AddressSanitizer enabled. In this case, AC_SEARCH_LIBS([dlopen]...) reports no lib is required, but tests using dlsym still require to link against -ldl. Change-Id: Ic619b0885688066b60c97caf1e2c7e5402c1d9f7
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 60b76b57..2a77d5e3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -49,7 +49,7 @@ libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined
if ENABLE_PLUGIN
libosmocore_la_SOURCES += plugin.c
-libosmocore_la_LIBADD += $(LIBRARY_DL)
+libosmocore_la_LIBADD += $(LIBRARY_DLOPEN)
endif
if ENABLE_MSGFILE