aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-05-13 11:35:30 +0200
committerHarald Welte <laforge@gnumonks.org>2010-05-13 11:35:30 +0200
commit7b45d608872f17ab8b71d53a2d87e5f8d621b007 (patch)
tree6bc733abbfda569244cbda5cb63883d4c6374285 /src/Makefile.am
parent7638af95fd08213aef4adb3c6399975fe3621855 (diff)
Add new 'rate counter' implementation to libosmocore
A 'rate counter' is a counter that counts events but also keeps track of the rate of events (per second, minute, hour and day). 'rate counters' are generally abstracted in 'rate counter groups', which are instances of a 'rate counter group description'. This way we can have e.g. a description describing what kind of counters a BTS (or TRX) has - and we can then create one instance of that group for every BTS or TRX that exists.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 20e99db3..ce063d05 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -10,7 +10,7 @@ lib_LTLIBRARIES = libosmocore.la
libosmocore_la_SOURCES = timer.c select.c signal.c msgb.c rxlev_stat.c \
tlv_parser.c bitvec.c comp128.c gsm_utils.c statistics.c \
write_queue.c utils.c rsl.c gsm48.c gsm48_ie.c \
- logging.c gsm0808.c
+ logging.c gsm0808.c rate_ctr.c
if ENABLE_TALLOC
libosmocore_la_SOURCES += talloc.c